Outage affecting searches
Resolved

All systems are back to normal. We apologize for the inconvenience this may have caused.

Sat, Sep 13, 2025, 01:22 PM
(2 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

All systems are back to normal. We apologize for the inconvenience this may have caused.

Sat, Sep 13, 2025, 01:22 PM

Investigating

We’re currently investigating issues that are causing searches to stall.

Sat, Sep 13, 2025, 12:47 PM(34 minutes earlier)